Reduced web and app performance
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted Oct 10, 2020 - 10:51 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 09, 2020 - 16:03 CDT
Investigating
We are currently investigating this issue.
Posted Oct 09, 2020 - 08:43 CDT
This incident affected: Munzee Website and Munzee API.