Elevated Website Errors
Incident Report for Munzee
Resolved
Things have returned to a stable state. Sorry about that.
Posted over 1 year ago. Jun 04, 2017 - 12:04 CDT
Investigating
We're experiencing an elevated level of Website errors and are currently looking into the issue.
Posted over 1 year ago. Jun 04, 2017 - 11:46 CDT