Munzee Website offline
Incident Report for Munzee
Resolved
This incident has been resolved. The website is back up and running.
Posted Jun 02, 2021 - 17:40 CDT
Investigating
We are currently investigating the issue.
Posted Jun 02, 2021 - 17:30 CDT
This incident affected: Munzee Website.