SSL Certificate Issues
Incident Report for Munzee
Resolved
We believe everything has been resolved with the https errors and ssl certificates on our various websites. We take your security and privacy very seriously and want you to have the best experience possible. If you notice any issues, please email support@munzee.com.
Posted about 1 year ago. Jun 21, 2017 - 16:52 CDT
Update
We are still aware of this issue and still working on it with our partners.
Posted about 1 year ago. Jun 20, 2017 - 09:18 CDT
Investigating
We are currently having SSL Certificate issues on some of our domains. Please be patient while we work on this.
Posted about 1 year ago. Jun 19, 2017 - 20:56 CDT