Physical captures going to offline queue
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted Apr 08, 2021 - 11:50 CDT
Update
We are continuing to investigate this issue.
Posted Apr 08, 2021 - 11:50 CDT
Investigating
We are currently investigating this issue.
Posted Apr 08, 2021 - 11:31 CDT
This incident affected: Mobile App.