Munzee Website Map Issue
Incident Report for Munzee
Resolved
We have resolved the issue and the website map is working again.
Posted Jan 26, 2022 - 15:38 CST
Identified
We have identified the issue with the map and are working on an update.
Posted Jan 26, 2022 - 13:16 CST
Investigating
We are currently investigating an issue with the Munzee website Map. Will update here as more details become available. Mobile map is currently working.
Posted Jan 26, 2022 - 12:32 CST
This incident affected: Munzee Website.