Redeem store
Incident Report for Munzee
Resolved
The redeem store is back. www.munzee.com/redeem - please report any issues to support@munzee.com
Posted Oct 04, 2021 - 11:35 CDT
Identified
We have identified an issue with the Redeem store. All options have been temporarily removed from munzee.com/redeem while we fix the problem. We expect it will return later today but will update further here.
Posted Oct 04, 2021 - 05:35 CDT
This incident affected: Munzee Website.