Munzee Website Map
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted Apr 07, 2021 - 12:41 CDT
Investigating
Currently an issue with the online Munzee Website map not displaying correctly. Looking into the issue.
Posted Apr 07, 2021 - 12:29 CDT
This incident affected: Munzee Website.