Site Upgrade
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted Aug 13, 2020 - 14:40 CDT
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 13, 2020 - 14:26 CDT
This incident affected: Munzee Website, Munzee API, and Database Infrastructure.