Munzee Web site - Destination Renovation Features
Incident Report for Munzee
Resolved
All Destination Renovation features and functionality are now working on munzee.com
Posted Mar 12, 2020 - 11:44 CDT
Monitoring
We do have minor changes that will be updated on the web site in the morning (MHQ Time) for the newly released Destination Renovation features and functionality. In the meantime, please use the Munzee App to access these features.
Posted Mar 10, 2020 - 19:32 CDT
This incident affected: Munzee Website.