Elevated Website Errors
Incident Report for Munzee
Resolved
Looks like things are good now. Thanks for being patient.
Posted about 1 year ago. Apr 12, 2017 - 19:39 CDT
Investigating
We're experiencing an elevated level of website errors and are currently looking into the issue.
Posted about 1 year ago. Apr 12, 2017 - 19:32 CDT