Elevated Website Errors
Incident Report for Munzee
Resolved
All fixed. Enjoy your day!
Posted over 1 year ago. May 31, 2017 - 12:46 CDT
Investigating
We're experiencing an elevated level of website errors and are currently looking into the issue.
Posted over 1 year ago. May 31, 2017 - 12:35 CDT