Elevated Website Errors
Incident Report for Munzee
Resolved
Everything is good now. Please let us know if you see issues at support@munzee.com.
Posted over 1 year ago. Apr 04, 2017 - 15:41 CDT
Investigating
We're experiencing an elevated level of website errors and are currently looking into the issue.
Posted over 1 year ago. Apr 04, 2017 - 14:38 CDT