Elevated Website Errors
Incident Report for Munzee
Resolved
All fixed. Hope you had a great weekend everyone.
Posted about 1 year ago. Apr 23, 2017 - 21:15 CDT
Identified
We're experiencing an elevated level of website errors and are currently looking into the issue.
Posted about 1 year ago. Apr 23, 2017 - 21:07 CDT