Munzee Website Issues
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted Mar 24, 2021 - 11:34 CDT
Investigating
We are currently investigating the issue.
Posted Mar 24, 2021 - 11:15 CDT
This incident affected: Munzee Website.