General Slowness
Incident Report for Munzee
Resolved
All systems are back to a normal state. Thanks for being patient.
Posted 8 months ago. Feb 08, 2018 - 13:34 CST
Investigating
We are currently investigating problems with website and app being slow or not responding.
Posted 8 months ago. Feb 08, 2018 - 10:56 CST