Slow gameplay
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 20, 2018 - 09:13 CDT
Monitoring
We are in the process of activating some backend updates right now. Gameplay can be slow and short outages can occur. We'll update you on the process.
Posted about 2 months ago. Oct 19, 2018 - 06:58 CDT
This incident affected: Munzee Website and Munzee API.