Munzee Website Changes
Incident Report for Munzee
Resolved
We have switched some internals to make the website more stable. If you notice any issues, please email support@munzee.com.
Posted over 1 year ago. Jun 12, 2017 - 10:33 CDT
Monitoring
We are going to be making changes to munzee.com in an attempt to make portions of the site more stable. You may notice some issues over the next few days, but we are aware of them and will make fixes as necessary.
Posted over 1 year ago. Jun 12, 2017 - 09:58 CDT