Reduced web and app performance
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted Dec 06, 2020 - 13:04 CST
Update
We are continuing to investigate this issue.
Posted Dec 06, 2020 - 07:53 CST
Investigating
We are currently investigating this issue.
Posted Dec 06, 2020 - 07:45 CST
This incident affected: Munzee Website and Munzee API.