Munzee Store
Incident Report for Munzee
Resolved
We have identified the issue and opened the store back up. Sorry for the inconvenience.
Posted about 1 year ago. Aug 23, 2017 - 10:23 CDT
Update
We are currently working with the Shopify developers to figure out exactly what the root cause is and then make steps to fix it.
Posted about 1 year ago. Aug 23, 2017 - 08:08 CDT
Investigating
We are getting reports of being unable to checkout on store.munzee.com. We are looking into it.
Posted about 1 year ago. Aug 23, 2017 - 06:04 CDT