Elevated Website Errors
Incident Report for Munzee
Resolved
Everything is good now. Enjoy the weekend!
Posted over 1 year ago. Jul 22, 2017 - 12:42 CDT
Investigating
We're experiencing an elevated level of Website errors and are currently looking into the issue.
Posted over 1 year ago. Jul 22, 2017 - 12:37 CDT