Delivery of credits/munzees not working properly
Incident Report for Munzee
Resolved
This incident has been resolved. All purchases and queued items to be delivered are now completing properly. Apologies for the tech issues, but you'll be getting a card soon!
Posted Dec 10, 2020 - 09:54 CST
Investigating
This is a bigger issue than we thought. It's attached to all things that would normally auto deploy or deliver credits or munzees.
That includes:
Purchases through the store
Spyderbot for Day 7 ZeeOps
Mistletoe card for Tier 2 & 3
Delivery of ZeeCred buyout briefcase/NVG

All of this is documented and will be delivered. Thanks for your patience while we work it out!
Posted Dec 10, 2020 - 08:06 CST
This incident affected: Munzee Website and Munzee Store.