Website Slowness
Incident Report for Munzee
Resolved
Things seem stable now! A fun way to end 2016.
Posted 3 months ago. Dec 31, 2016 - 21:47 CDT
Update
We now have our 3rd party engineers looking into it.
Posted 3 months ago. Dec 31, 2016 - 19:14 CDT
Investigating
There seems to be some issues with the website - www.munzee.com. Looking into it.
Posted 3 months ago. Dec 31, 2016 - 18:31 CDT