Elevated Website Errors
Incident Report for Munzee
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 26, 2017 - 20:56 CDT
Monitoring
Things seem to be stable again. Will certainly keep an eye on it.
Posted over 1 year ago. Mar 26, 2017 - 17:59 CDT
Investigating
We're experiencing an elevated level of Website errors and are currently looking into the issue.
Posted over 1 year ago. Mar 26, 2017 - 17:52 CDT