Munzee Website
Incident Report for Munzee
Resolved
Everything seems to be back to normal. Please email support@munzee.com if you find any issues.
Posted 8 months ago. Oct 18, 2017 - 11:38 CDT
Identified
We believe we have identified the issue and are bringing all aspects of the site back online. We are going through the site now checking every page to make sure it's an optimize experience. If you notice any issues. please email support@munzee.com.
Posted 8 months ago. Oct 18, 2017 - 11:18 CDT
Investigating
We are currently having a few layout issues with the Munzee website. We are working on it.
Posted 8 months ago. Oct 18, 2017 - 10:16 CDT