Elevated Website Errors
Incident Report for Munzee
Resolved
Everything is good now. Sorry about that!
Posted about 1 year ago. May 29, 2017 - 18:07 CDT
Investigating
We're experiencing an elevated level of Website errors and are currently looking into the issue.
Posted about 1 year ago. May 29, 2017 - 17:54 CDT