Performance Issues
Incident Report for Munzee
Resolved
All Munzee and Eventzee services are back to a stable state.
Posted 5 months ago. Jan 16, 2018 - 11:31 CST
Identified
We are currently looking into an issue with degraded performance of the Munzee and Eventzee services.
Posted 5 months ago. Jan 16, 2018 - 07:41 CST