Elevated Website Errors
Incident Report for Munzee
Resolved
We believe things are stable again. Munzee On!
Posted 3 months ago. Sep 08, 2017 - 01:33 CDT
Investigating
We're experiencing an elevated level of Munzee Website errors and are currently looking into the issue.
Posted 3 months ago. Sep 08, 2017 - 01:25 CDT