Get in touch
Back
Maintenance

Scheduled Maintenance Notice - December 9, 2025 at 19:00 MHQ

Completed .

Munzee.com Website Munzee.com User Pages Munzee API Servers Munzee Web Map Munzee Mobile App Munzee Store
Completed

Maintenance completed

Posted .
Started

We'll be performing backend system updates tonight, Thursday, December 9, 2025 at 19:00 MHQ. While we don't expect major disruptions to the app, it's possible some services may experience some degradation. We'll be closely monitoring the system to ensure everything continues running smoothly. We will post any necessary updates to status.munzee.com. Thank you for your patience!

Posted .