Get in touch
Back
Downtime

Firebase Authentication Down

Started , resolved .

Munzee.com Website Munzee.com User Pages Munzee Web Map Munzee Mobile App Munzee Store
Resolved

Everything should be back up and running! If anyone is still experiencing any issues, please reach out to support@munzee.com

Posted .
Created

Firebase is currently having issues with their authentication system, which is causing issues with both the Munzee App and Website. We will let everyone know as soon as it is back up and running.

Posted .