Back
Degraded

Apple Maps - Currently Investigating Missing Street Names and Labels
Started 10 Apr at 04:21am CDT, resolved 10 Apr at 11:13am CDT.
Munzee Mobile App
Resolved
The team has resolved the issues with the map! Please restart the app to pull down the latest over-the-air update. It looks like Apple had released some updates related to their maps, which caused some issues here. We appreciate your patience as the team worked to resolve them. If you're still noticing any issues with the map, please send a support request to support@munzee.com
Posted 10 Apr at 11:13am CDT.

Created
The team is currently looking into missing street names and places labels on Apple Maps.
Posted 10 Apr at 04:21am CDT.