Get in touch
Back
Degraded

Currently Investigating Treehouses & Skylands

Started 13 Feb at 05:23pm CST, resolved 18 Feb at 03:17pm CST.

Munzee Web Map Munzee Mobile App
Resolved

We appreciate your patience as we've continued working on improvements to bouncer behavior with Treehouses and Skylands. Our team has been actively making tweaks and fixes, and we’ve seen some positive improvements since those updates were pushed. We’ll continue to monitor and adjust as needed to find the best balance. Thank you for your support and for being part of the Munzee community!

Posted 18 Feb at 03:17pm CST.
Created

We want to take a moment to acknowledge the recent changes in bouncer behavior with Treehouses and Skylands. Our team has been actively investigating the situation and working on updates to improve it. We truly appreciate your patience and understanding as we continue to dedicate our time and focus to this issue. We’ll share more updates as we have them. Thank you for being part of the Munzee community. 💚

Posted 13 Feb at 05:23pm CST.