Get in touch
Back
Maintenance

Follow-Up Scheduled Maintenance

Completed 16 Oct at 11:00pm CDT.

Munzee.com Website Munzee.com User Pages Munzee API Servers Munzee Web Map Munzee Mobile App
Completed

Maintenance completed

Posted 16 Oct at 11:00pm CDT.
Started

We'll be following up on the backend system updates tonight, Wednesday, October 16th, at 19:00 MHQ. While we don't expect major disruptions, you may experience some app slowdowns during this time. We'll be closely monitoring the system to ensure everything continues running smoothly. We will post any necessary updates to status.munzee.com. Thank you for your patience!

Posted 16 Oct at 07:00pm CDT.
//]]>