Get in touch
Back
Maintenance

Scheduled Maintenance Notice

Completed 14 Oct at 10:00pm CDT.

Munzee.com Website Munzee.com User Pages Munzee API Servers Munzee Web Map Munzee Mobile App
Completed

Maintenance completed

Posted 14 Oct at 10:00pm CDT.
Started

We'll be performing backend system updates tonight, Monday, October 14th, at 18:00 MHQ, with a potential follow-up maintenance tomorrow, Tuesday, October 15th, at the same time. While we don't expect major disruptions, you may experience some app slowdowns during this time. We'll be closely monitoring the system to ensure everything continues running smoothly. We will post any necessary updates to status.munzee.com. Thank you for your patience!

Posted 14 Oct at 06:00pm CDT.