Get in touch
Back
Degraded

Currently Investigating Issues

Started 28 Feb at 10:57am CST, resolved 29 Feb at 08:57pm CST.

Munzee.com Website Munzee Web Map Munzee Mobile App Munzee Store
Resolved

The system has returned to fully operational and scatters should be archiving when expired. Munzee On!

Posted 29 Feb at 08:57pm CST.
Updated

We have identified and resolved the main issues related to archiving and delayed processing of orders, etc. Some scatters may still be slow to archive as the queue is still catching up with all of the Leap Day scatters from earlier today. The team will continue to monitor the system for now to ensure things continue to run smoothly.

Posted 28 Feb at 07:49pm CST.
Created

We're currently investigating issues with scatters not leaving the map. Other areas of the game may also be impacted and orders may be delayed from the store. We will post another update as soon as the issues have been resolved.

Posted 28 Feb at 10:57am CST.