Get in touch
Back
Degraded

Event section of Redeem store offline

Started 10 Feb at 12:40pm CST, resolved 13 Feb at 02:55pm CST.

Munzee.com Website
Resolved

The event section of the Redeem store is back online now. Thank you for the patience.

Posted 13 Feb at 02:55pm CST.
Created

The "cake credits" section of the redeem store has been taken offline until Monday. The actions of some players have caused us to take this action, the store itself is not having any issues.

Posted 10 Feb at 12:40pm CST.