Get in touch
Back
Degraded

Mailbox Double Point Weekend Issues

Started 29 Dec at 09:02am CST, resolved 29 Dec at 10:21am CST.

Munzee.com Website Munzee Mobile App
Resolved

We have identified and resolved the issue. Double points should be working as expected across all bouncers now. If you're still noticing any issues, please reach out to support@munzee.com with details so that we can investigate further.

NOTE - It will take some time to retroactively fix the missing double points on bouncers from earlier captures, but those will also be resolved and rewarded. Thank you for your patience.

Posted 29 Dec at 10:21am CST.
Created

We're currently investigating why double points are not always awarded for bouncers. Will keep everyone updated as soon as there is a fix in place.

Posted 29 Dec at 09:02am CST.