Get in touch
Back
Degraded

Slowness and Outages

Started 8 Oct at 08:58am CDT, resolved 8 Oct at 06:46pm CDT.

Munzee.com Website Munzee Web Map Munzee Mobile App
Resolved

Game operations have returned to normal. The team will continue to investigate and work to improve the performance, and identify and implement code changes to address the recent system issues.

Posted 8 Oct at 06:46pm CDT.
Created

No further details at this time.

Posted 8 Oct at 08:58am CDT.