Get in touch
Back
Degraded

App and Website Issues

Started 7 Oct at 08:09am CDT, resolved 7 Oct at 03:10pm CDT.

Munzee.com Website Munzee Web Map Munzee Mobile App
Resolved

Several fixes have been applied over the last few hours and stability has returned. Additional monitors are in place as we move forward.

Posted 7 Oct at 03:10pm CDT.
Created

We are investigating more issues with the app and website. We will update here with additional information.

Posted 7 Oct at 08:09am CDT.