Get in touch
Back
Degraded

Currently investigating issues

Started 6 Oct at 07:41am CDT, resolved 6 Oct at 12:03pm CDT.

Munzee.com Website Munzee Web Map Munzee Mobile App
Resolved

Our team has resolved a handful of issues regarding the downtime this morning, and both web and app are working currently. We're still investigating some slow speeds, and will continue to monitor throughout the day. Thank you for your patience.

Posted 6 Oct at 12:03pm CDT.
Created

Currently investigating issues

Posted 6 Oct at 07:41am CDT.