Get in touch
Back
Resolved

Currently investigating issues

Started 3 Oct at 07:05am CDT.

Munzee.com Website Munzee.com User Pages Munzee API Servers Munzee Web Map Munzee Mobile App
Created

The system has returned to fully operational, and we will continue to work to improve the performance, and identify and implement code changes to address the current overnight system issues.

Posted 3 Oct at 07:05am CDT.