Get in touch
Back
Degraded

Flat DHS Scatters Not Available

Started 11 Jun at 04:40pm CDT, resolved 12 Jun at 12:25pm CDT.

Munzee Mobile App
Resolved

We sincerely apologize for the inconvenience caused by the premature removal of the Flat DHS Scatters from the map.

To rectify this situation, we have taken the following steps:

Flat DHS Scatter Event Extension: We have extended the Flat DHS scatter event until Sunday, June 18th, at 23:59 MHQ. This will give all players an opportunity to capture the Flat DHS Scatters they missed during the downtime.

Screen Cleaning Badge: Additionally, we will be automatically granting the Screen Cleaning Badge to any players who captured at least 3 or more Flat DHS during the final 12 hours the scatters should have been active. This is our way of acknowledging your dedication and efforts despite the unfortunate circumstances.

We want to express our gratitude to the Munzee community for your patience and understanding during this time. We genuinely appreciate your continued support, and we will continue working tirelessly to ensure a seamless and enjoyable experience for all players.

Posted 12 Jun at 12:25pm CDT.
Created

We're aware of an issue that caused the Flat DHS scatter event to end earlier than expected. We apologize for any frustrations and will post an announcement tomorrow with our plan to make this up to those affected.

Posted 11 Jun at 04:40pm CDT.