Back
Downtime

Munzee Calendar Website Offline
Started 10 May at 07:03pm CDT, resolved 10 May at 07:24pm CDT.
Munzee.com Website
Resolved
Issue has been resolved. The Munzee Calendar Website should be back up and running.
Posted 10 May at 07:24pm CDT.

Created
We're currently investigating an issue with the Munzee Calendar Website: https://calendar.munzee.com/ Will post an update once it has been resolved.
Posted 10 May at 07:03pm CDT.