Get in touch
Back
Downtime

Reinvestigating issues

Started 7 May at 01:50pm CDT, resolved 7 May at 09:33pm CDT.

Munzee.com Website Munzee API Servers Munzee Web Map Munzee Mobile App
Resolved

Servers are responding, and game operations have returned to normal. We apologize for the issues again today and appreciate your patience as we worked to resolve them.

Posted 7 May at 09:33pm CDT.
Created

Currently reinvestigating issues

Posted 7 May at 01:50pm CDT.