Get in touch
Back
Downtime

Currently investigating issues

Started 7 May at 11:42am CDT, resolved 7 May at 01:29pm CDT.

Munzee.com Website Munzee API Servers Munzee Web Map Munzee Mobile App
Resolved

Servers are responding, and game operations have returned to normal. We apologize for the issues again today and appreciate your patience as we worked to resolve them.

Posted 7 May at 01:29pm CDT.
Created

Currently investigating issues

Posted 7 May at 11:42am CDT.