Get in touch
Back
Maintenance

Munzee.com Web Cache Software / Hardware Update

Completed 6 Apr at 05:05pm CDT.

Munzee.com Website
Updated

The update completed without incident. If you find an issue, please logout and then log back in. If an issue persists, please contact support using the get in touch button on the top right of this page.

Posted 6 Apr at 07:29pm CDT.
Completed

Maintenance completed

Posted 6 Apr at 05:05pm CDT.
Started

We are doing a quick update of munzee.com's web cache software/hardware at currently - It should only take a few minutes, but you may find that the website is slow or unresponsive during this time. The update will also potentially log everyone out, so once it's complete you may need to log in again to the web site.

Posted 6 Apr at 05:01pm CDT.