Get in touch
Back
Resolved

Munzee App Map Offline

Started 15 Mar at 10:12pm CDT.

Munzee Mobile App
Created

The fix has been pushed, and the map is working again. Players will need to force close the app, and let the over the air update install (if it gets to 95% and then takes a bit to finish, please be patient, it will update). Munzee On!

Posted 15 Mar at 10:12pm CDT.