Get in touch
Back
Maintenance

System and Database Maintenance

Completed 13 Jan at 11:30pm CST.

Munzee.com Website Munzee.com User Pages Munzee API Servers Munzee Web Map Munzee Mobile App
Completed

Maintenance completed

Posted 13 Jan at 11:30pm CST.
Started

We will be doing some system and database maintenance for a short period beginning at 11:10 MHQ Time. It should only last a few minutes, but will keep things updated on the status pages.

Posted 13 Jan at 11:10pm CST.