Get in touch
Back
Degraded

Issue with fulfilling orders and rewards

Started 4 Jan at 12:40pm CST, resolved 4 Jan at 03:51pm CST.

Munzee Store
Resolved

We have fixed the issue with the 3rd Party Libraries and approximately 30 minutes ago all awarding and purchases began processing and fulfilling in the order it was queued. It will take a bit to process things, but we will be monitoring and update the status here if it changes.

Posted 4 Jan at 03:51pm CST.
Created

We have a backend server issue with a third party library which is causing a delay in order fulfillment and reward fulfillment.

Posted 4 Jan at 12:40pm CST.