Get in touch
Back
Resolved

Issue with Memory Caching Servers

Started 2 Jan at 04:53pm CST.

Munzee.com Website Munzee Web Map Munzee Mobile App
Created

We had an issue with one of our memory caching servers, but it has been resolved, and all systems are now responding properly

Posted 2 Jan at 04:53pm CST.